Resolved
After our fix we have noticed the delay returning to standard levels.
Identified
We have found the core issue and are working hard on a fix.
Expect to be fixed in at most 24 hours.
Investigating
We have noticed severe delay with responses from the Discord module.
We are currently investigating the root cause.